---
title: 'Ошибка 504 524 Gateway Timeout (решено) | Zomro'
description: 'Ошибка 504 524 Gateway Timeout — это код состояния HTTP, который означает, что один сервер не получил своевременный ответ от другого сервера, к которому он обращался...'
image: 'https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637108_1.png'
---

![opened image]()

  * [Zomro](https://zomro.com/rus/)
  * [FAQ](https://zomro.com/rus/blog/faq/)
  * Ошибка 504 524 Gateway Timeout (решено) 



# Ошибка 504 524 Gateway Timeout (решено)

12-07-2022

Ошибка 504 524 Gateway Timeout — это код состояния HTTP, который означает, что один сервер не получил своевременный ответ от другого сервера, к которому он обращался, при попытке загрузить веб-страницы или выполнить другой запрос браузера.  


**Причины ошибок 504 524 Gateway Timeout**

  
В большинстве случаев ошибка 504 или 524 Gateway Timeout означает, что запрос который отправлен на сервер занимает времени чем установлено на сервере, или например на CloudFlare. Обычно это могут быть задания CRON, или любые другие запросы которые требуют большое количество времени на исполнение.   
  
Что касается ошибки 504 или 524 которую мы видим на Cloudflare, то это говорит об успешном подключении к исходному веб-серверу, но источник не предоставил HTTP ответ по истечении 100 секунд, которое установлено по умолчанию. (Это ограничение установлено на бесплатном тарифе). Корпоративные клиенты могут увеличить время ожидания до 600 секунд.  
  
Но в этой статье вы сможете узнать как можно настроить VPS сервер так что бы повысив лимиты, мы могли обойти ограничение ClodFlare в 100 секунд.  
  
  
Если у нас установлена панель ISP Manager, авторизуемся в панели под пользователем root, выбираем WWW-Домены, дале отмечаем галочкой нужный домен, и нажимаем Файлы конфигурации.   
  
  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 1](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637108_1.png)  
  
Для сайтов на панели Vesta, конфиги можно найти по следующему пути:
    
    
    Для правки nginx /home/admin/conf/web/******.nginx.ssl.conf
    
    Для правки apache /home/admin/conf/web/******.httpd.ssl.conf

  
Для начала изменяем конфиг Apache, добавив туда директиву Timeout. Это необходимо сделать перед закрывающим тегом </VirtualHost>. Как показано на иллюстрации.  
  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 2](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637212_2.png)
    
    
    <VirtualHost 127.0.0.1:8080>
    ...
    
    TimeOut 1800  
    </VirtualHost>
    
    

  
Далее изменяем конфиг nginx, добавив в блок "location @fallback {...}" как показано на иллюстрации:

  
![Ошибка 504 524 Gateway Timeout \(решено\) - 3](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637271_3.png)  


Если сайт работает в режиме Apache (CGI, FastCGI), то:
    
    
    proxy_connect_timeout 1800;
    proxy_send_timeout 1800;
    proxy_read_timeout 1800;
    send_timeout 1800;

  
Если сайт работает в режиме PHP-FPM, то:
    
    
    fastcgi_connect_timeout 1800;
    fastcgi_send_timeout 1800;
    fastcgi_read_timeout 1800;
    send_timeout 1800;

Если такой таймаут необходимо применить для всех сайтов на этом сервере, что не рекомендуется, то данную конструкцию необходимо добавить в блок http серверного конфига nginx. Размещение**/etc/nginx/nginx.conf**  
  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 4](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637294_4.png)  
  
После этого точно такие же таймауты необходимо добавить в конфигурационные директивы PHP **max_input_time** и **max_execution_time**. Это необходимо сделать в настройках выбранной версии PHP которая установлена на данный сайт.  
  
  
Если у вас установлена панель ISP Manager, необходимо перейти "**Настройки web-сервера** ", дале выбрать пункт "PHP", отметить галочкой нужную версию PHP и нажать "**Расширенные настройки** "  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 5](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637321_5.png)

В поиске пишем **max_input_time** и **max_execution_time** и выставляем значение в **1800**. Повторюсь, оно должно быть во всех конфигах одинаково!

  
![Ошибка 504 524 Gateway Timeout \(решено\) - 6](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637416_6.png)  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 7](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637366_7.png)  
  
Если у вас установлена Vesta, то необходимо перейти в меню Server и выбрать httpd или php-fpm.  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 8](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637410_61.png)  
  
![Ошибка 504 524 Gateway Timeout \(решено\) - 9](https://dx86q6oq7ry0e.cloudfront.net/uploads/media/blog/a48@server-panel.net/2022/07/01/1657637456_71.png)

Либо из консоли править файл **/etc/php.ini** и выставить значение в **1800** для **max_input_time** и **max_execution_time**.  
  
В случае если импорт товаров не проходит или _**110: Connection timed out**_ _**fastcgi://unix:/var/www/php-fpm/2.sock**_  
  
Добавляем следующие строки в **location /**
    
    
    proxy_http_version 1.1;
    proxy_set_header Connection "";

  
Так же можно добавить таймауты:
    
    
    proxy_connect_timeout 1800;
    proxy_send_timeout 1800;
    proxy_read_timeout 1800;
    send_timeout 1800;

  
После чего перезапускаем **httpd** и **nginx** , а так же **php-fpm** если он установлен.  
  
Для **Centos** :  

    
    
    systemctl restart httpd
    systemctl restart nginx
    systemctl restart php-fpm

  
  
Для **Ubuntu** :
    
    
    systemctl restart apache2
    systemctl restart nginx
    systemctl restart php-fpm

  
Запускаем задачу или нужный скрипт и наслаждаемся его работой.

Похожие статьи

[Как поднять OpenSSH на Windows 2016](https://zomro.com/rus/blog/faq/405-how-to-raise-openssh-on-windows-2016) [Ошибка 406 Not Acceptable](https://zomro.com/rus/blog/faq/491-error-406-not-acceptable) [Как быстро настроить SFTP сервер в Windows](https://zomro.com/rus/blog/faq/394-quick-setup-of-the-sftp-server-on-windows-server) [Как купить лицензию ISPmanager](https://zomro.com/rus/blog/faq/625-how-to-purchase-an-ispmanager-licence) [Включаем удалённый доступ к MySQL/MariaDB на сервере Ubuntu + HestiaCP](https://zomro.com/rus/blog/faq/608-enable-remote-access-to-mysqlmariadb-on-ubuntu-server-hestiacp)

[ Выделенный сервер с GPU от €174.80/мес ](/dedicated-servers/type=gpu)
